Press "Enter" to skip to content

2.60b (2.55+) ET server patch with 2.55 client backward compatibility

In order to the regular latest 2.60b Server patch i noticed the high amout of version 2.55 running servers in the Enemy Territory community. Due the intolerable issues and bugs on servers running with this outdated 2.55 server i decided to try some reverse engineering on the baseline of the newest server version 2.60b with the goal to allow older clients to connect to a 2.60b based server version (but shown as 2.55 version in game browser).

Some notable advantages:

+ many security and bug fixes
+ less cpuload
+ more server stability and performance

How patch to 2.55+:

You need a 2.55 installation of your server

Replace the original et.x86/et.exe with the patched etded.x86/etded.exe

Pay attention to your start scripts to set the right target to instead of!!!

Update: Every client version(2.55,2.56,2.60,2.60b) works fine with PunkBuster.

Important note: You need to delete the “etmain/mp_bin.pk3”, otherwise you could get a error(“Couldn’t load an official pak file”) during connection.

One Comment

  1. Rob MacArthur
    Rob MacArthur 3 October 2010

    hope this works

Leave a Reply

Your email address will not be published. Required fields are marked *